Smelling Coolant

bijanjames

Adventurer
2011 Nissan Frontier Prox
I've noticed that recently when I drive the truck to operating temp I start to smell coolant, Its coming from the engine bay only, not through the vents, and I can't smell it in the truck. I've checked the radiator fluid several times, both cold and hot, and it is always 1" above max level. I've looked for leaks on the garage floor and pooling on top of the skid and don't see anything. Operating temperature has not change at all. I've done the routine forum search and nothing in particular seems to pop out. I'm taking it to a local shop today to get a pressure test done on the cooling system and have everything looked over. Anyone else notice a slight coolant smell? especially when it's pulled in the garage after being driven.

Thanks for your advice.
 

trollhattan

Observer
Funny you have that issue. I have a 2011 Xterra Pro4X and have had that occasional coolant smell as well but never found a leak nor did the level go down (50k+ miles).

Before you take it to a shop, how are the cap on the radiator and the pressure cap on the reservoir tank? You've said you checked it both hot and cold but was the engine running or off? Since you mentioned that its above max level, perhaps there is just too much pressure with the extra coolant and its being vented through the reservoir cap until its at correct level.
 

Obrianmcc

Observer
Check your hose connections to the radiator and heater core ... I've seen similar reports where the hoses were weeping a bit, but not enough to produce an actual leak
 

bijanjames

Adventurer
Funny you have that issue. I have a 2011 Xterra Pro4X and have had that occasional coolant smell as well but never found a leak nor did the level go down (50k+ miles).

Before you take it to a shop, how are the cap on the radiator and the pressure cap on the reservoir tank? You've said you checked it both hot and cold but was the engine running or off? Since you mentioned that its above max level, perhaps there is just too much pressure with the extra coolant and its being vented through the reservoir cap until its at correct level.
I took it in and had the coolant system pressure checked and as I suspected everything tested fine. They went through the whole system and said that it was in excellent shape. The mechanics guess was as good as ours as to whats wrong, but nothing seemed out of the ordinary.
 

Dave Kay

Adventurer
Even after a pressure testing looked good I would caution you to keep close tabs on your coolant level. That smell is vapor of coolant and it is coming from someplace.

A very similar thing happened to me when I could smell coolant odor emanated from my K30's 6.2L Detroit Diesel cooling sys. After checking and rechecking the radiator level for what seemed like weeks, never showing low, I ignored the issue for awhile. Then one day I was in a long line waiting at a fast food drive through when I noticed my temp gauge was way high and with it, that coolant smell. Lucky I always carry a 5-gal jerrycan of water on board and darned if I didn't put two whole gallons in that radiator before it was full~!

Later, I checked out the sys with a cheap pressure tester from Harbor Freight and sure enough, like OBrianmcc said, it was a tiny little weepy leakage at the top hose. Reason I never saw it before was because the leak was so small that it would drip ever so slightly and then evaporate under the goose-neck, it never left a puddle anywhere.
 
Top