Post your Mitsubishi Pajero Pics

Liam5638

New member
Here is my old 2003

http://www.cardomain.com/ride/2934916

03 was a unique year as it was the only time here in the states you could get the NP (3.8L, updated drivetrain, ect...) model in the XLS trim. Pretty bare bones inside for a modern rig.

Sold it, but just picked up another low mile 2003 XLS in black.

When I head out for an excursion I take off the running boards and throw the maggiolina on top. Works great.
I hope he still looks like in the picture and still serves you!
 

Taylor1

Observer
I have 265K on my 99 winter package now - 40k miles are mine since November 2016. A couple pictures below are from fishing exploring Cape Lookout on the NC Outer Banks back in May. The others are from the camping road trip from Big Ivy Pisgah National Forest to Knoxville TN to Fontana Lake/Dam in Nantahala National Forest the weekend after July 4th.20190517_133923 (Large).jpg20190518_175305 (Large).jpg20190706_181050 (Large).jpg20190706_181116 (Large).jpg20190706_194654 m.jpg
 

JamesW

Adventurer
Done a bit of tidying to my own, and I'm just finished building the 3fd iteration of my rear storage system. Also carpeted the interior plastics. I'm going to put another USB charger + accessory socket, and a small inverter into the gaps on the sides of the drawers.

No more body lift either, just hacked away at the inner arches to fit the 35s


Sent from my ONEPLUS A6003 using Tapatalk
 

nomadsurfer

New member
Taylor1

That’s my doppelgänger! I’m also at ~260k.

Small oil leak, and ticks every once and a while but she’s solid! These things are tanks

What manual hubs are you running? I’m about to do the swap myself to some i just got off Amazon
 

Taylor1

Observer
Taylor1

That’s my doppelgänger! I’m also at ~260k.

Small oil leak, and ticks every once and a while but she’s solid! These things are tanks

What manual hubs are you running? I’m about to do the swap myself to some i just got off Amazon
Mine has the stock automatic hubs. I pulled the center caps and trim latch rings after discount tire broke a couple not mounting them centered. Side note... it made a crazy wobble until I figured it out.

Sent from my SM-G970U using Tapatalk
 
Top