Jack's 2007 Chevy Build

Prerunnertaco

New member
I have a very slight rub mark on one of the ribs of the cast portion of the oil pan. 50k miles and so far; it hasn’t gotten worse or caused a problem.

Jack
Thank you for getting back to me mine rubs so bad when the passenger side flexes up it hits bad. Idk what could be causing the issue. I'm pretty lost at this point.
 

locrwln

Expedition Leader
Thank you for getting back to me mine rubs so bad when the passenger side flexes up it hits bad. Idk what could be causing the issue. I'm pretty lost at this point.
What bumpstops are you running? I have the WFO’s on mine. Maybe you need larger ones?

Jack
 

Prerunnertaco

New member
What bumpstops are you running? I have the WFO’s on mine. Maybe you need larger ones?

Jack
I just added longer ones. I made my own mounts like wfo s. Tim never ran bumps on his. I just check the whole thread again, He mentioned on his thread he can go full bump to frame rails without any contact of the drag link. I find that hard to believe since the vent tube will hit the motor mount before the driver side would hit the frame rail. Anyways I bumped lower and its fine now. Also I'm running wfo shock towers. I'm thinking these sit taller.

Jack can you take a measurement from the frame to the coilovet mount bolt. Just a rough measurement for me to compare if you don't mind?
 

locrwln

Expedition Leader
I just added longer ones. I made my own mounts like wfo s. Tim never ran bumps on his. I just check the whole thread again, He mentioned on his thread he can go full bump to frame rails without any contact of the drag link. I find that hard to believe since the vent tube will hit the motor mount before the driver side would hit the frame rail. Anyways I bumped lower and its fine now. Also I'm running wfo shock towers. I'm thinking these sit taller.

Jack can you take a measurement from the frame to the coilovet mount bolt. Just a rough measurement for me to compare if you don't mind?
I just so happen to read back through Tim's build thread a couple of days ago and saw the same thing. Not sure how that was possible either. Anyway, I measured on the back side of the C/O on the driver's side and it shows 17". Hope that helps.

Jack
 

locrwln

Expedition Leader
I just wanted to update this to let everyone know. After a lot of deliberation and soul searching; my wife and I decided to sell the truck and camper as a package. It was driven away yesterday.

For everyone that contributed to the thread and to those who followed along; thank you.

As for a plan of what is next, I don’t really have one.

Jack
 

Runfar21

Member
Ten years is a good run with the truck. Though I haven’t commented, I have read this thread thoroughly. One year ago it inspired the purchase, and now build, of a 2013 Sierra 2500 HD. I hope to see another full size GM but sounds like you may have exhausted that route….

All the best!
 

locrwln

Expedition Leader
It has been the longest I’ve ever kept a vehicle. I’m glad you were inspired and as I have stated before, I would buy another GM in a heartbeat and if I find the right one, it will probably follow me home.

Thank you,

Jack
 

RyanPartridge

Active member
I was sad to hear this, but congrats on the sale Jack!
Wish I would've known you were thinking of parting with the truck...I would've campaigned for that overhead attic you made and the EMP skid plates!
Can't wait to see what the next project is!
 

locrwln

Expedition Leader
It’s funny you mention the attic. I had removed it and put the back seat in; the new owner asked specifically for the attic and the homemade box we had in lieu of the back seat. So, we had to reinstall the attic and box.

Thank you, we were apprehensive right up until he drove it away and it’s still surreal.

Me too, just don’t know quite what that will be.

Jack
 
Top