Gen 2.5 Cannot disengage 4WD

Swift_45a

Observer
Hey, so I tried searching but came up empty as it said my query was to short or too long; anyhow, I bough a Gen 2.5 that needs some minor things (like the PS belt adjustment I rebumped earlier) here and there, and among them was the inability to disengage 4WD, I had this issue on my 96 SR when it sat for long periods of time and it got 'sticky' but I was always able to get it out into 2wd by putting it in neutral and rolling backwards down a hill.

I tried it this time with no luck, is there a special trick to the Gen 2.5 that I don't know about?

Thanks!
 

Swift_45a

Observer
No, physically its shifting in and out of the low and high gears like normal, but once I put in 2wd the lights won't stop flashing. This was a thing on Gen 2s when they were left idle for a while so I knew how to remedy it, but on a Gen 2.5 I just backed up for nearly 10 blocks down a hill and still it wouldn't do a thing.

Maybe I'll post a video tomm to show what I mean.
 

DirtyDC05

Adventurer
Have you checked you vacuume line off the intake manifold ? Drivers side if it comes loose or is cracked it will not disengage
 

Salonika

Monterror Pilot
As far as I know it’s the same super select system on both trucks. Looks like this time you will need to do some hands on troubleshooting. There is a ton of existing info on this if you google it. You probably have some loose vacuum hoses or a failing solenoid valve. A couple years ago I went through all of my vac lines and just trimmed off the tips of the hose and pushed them back on, made a huge difference. The problem you describe is most likely related to the vacuum system that controls the front diff clutch.
 
Top