GAIA Issue

X-plorenow

Adventurer
OK I am stumped. I am a long time GAIA user and feel very comfortable with the tool. I got a new Android phone and just installed GAIA. I try and login and it says Incorrect password. I have tried the same login on two different computers, works fine, no issues. I even tried logging in on chrome on my phone, logs in no problem. I have uninstalled GAIA and reinstalled. I even uninstalled and restarted, no luck.

I have submitted a question on GAIA's site but wanted to see if anyone here had the same issue.

Anyone run into this?
 

Howard70

Adventurer
Definitely sounds odd. Assume you are certain that the email address entered before the password is the same? If you are a premium member you can call them - rarely get a tech immediately, but I find leaving a voice mail can get a response quicker than email. Unfortunately, you may be out of luck due to the long weekend coming up, but worth a try.

Howard
 

Laps

Active member
Maybe trying the "forgot your password" link? Then reset your password and use it for all of your devices after logging out from them all first.
 

Recommended books for Overlanding

Long Way Round: Chasing Shadows Across the World
by Ewan McGregor, Charley Boorman
From $14.59
Long Way Down: An Epic Journey by Motorcycle from Scotlan...
by Ewan McGregor, Charley Boorman
From $35.66
Cycling the Great Divide: From Canada to Mexico on North ...
by Michael McCoy, venture Cycling Association
From $9.99
Top