Dometic RC 2000 propane issue

sqrlnts

New member
hello Expedition Portal!!!

I recently purchased a Dometic RC 2000 3 way cooler. So far i have proven the cooler works on 120 VAC electric. I recently tried to start the unit on propan but was not successful. I purchased the cooler used and it did not come with the OEM regulator and hose. I am trying to use a regular BBQ grill propane canister (known to have fuel) and regulator (know to work on the BBQ).

To keep it short, the piezio sparks but I don't hear any propane coming out.

The manual says the multiple regulator unit (button B) has three positions, Closed-Max-Min.

They say to turn the regulator unit button B anti clockwise to the MAX position. This is opposite my valve. I open clockwise to MAX??

They then say to press button B down for 20-30 seconds. My button does not push down?? I removed the cover and knob on button B, and don't see how it is suppose to push down, just doesn't look to be built that way.

It says to hit the piezo several times and the flame indicator should go from white to green when lit. It does not light but the indicator does move when the piezo strikes.

Any ideas? I have heard that Dometic recently went out of business......

Thanks in advance for any help given!!!
 

camper357

Observer
rc200

I have the same unit, but your button setup sound different than mine. It seems like I have seen pictures of the same until with different controls.

Mine has two adjustable knobs. The knob on the left is the gas valve. It opens counter clockwise. This is the button that will press down. To start mine I turn it to just slightly counter clockwise, which is full gas. Then press down and hold the same knob and wait 20-30 seconds to prime the gas line. I then start pressing the piezo button until the pilot lights up. I keep the gas knob full pressed in for another 30 seconds making sure the indicator stays in the green after I let go of the gas knob.

On mine the other knob has numbers on it, and it is the thermostat for the 120 electric side. On 12v there is no adjustment, just on or off. IIRC you are not suppose to have the electricity plugged in while operating on gas and vice versa.

Here is a link to a manual. Mine is as pictured in the manual.

http://www.hamqsl.com/RC2000.pdf
 
Last edited:

Mike S

Sponsor - AutoHomeUSA
I think that you are either not getting gas, you are not letting the thermocouple warm up enough, or your thermocouple is defective.

I think that you will also find that this unit does very poorly when asked to chill when running on 12V. 120V is not a problem.
 

Lemsteraak

Adventurer
This should help

http://www.dometic.com/FileOrganizer/1-international/Operation%20&%20Installation%20Manuals/Refrigerators%20and%20Freezers%20-%20Portables/RC3000_EN.pdf

This is for the RC3000, yours uses the same mechanism, the 3000 is more of a picnic model.

What you have is very rare in the US, made by Electrolux before they spun it off to Dometic. Yes, Dometic is alive and well, and very huge, they don't mess with their own fridges much since they bought WAECO.

A little diagnostics, if your unit works on 120, then the absorption cooling unit is OK, so you don't have much to worry about. The principal of absorption cooling is old tech, but kind of magic. A heat source fires a small boiler that is filled with ammonia that boils and when it condenses absorbs the heat from the cold plate. So, on propane, there is a small jet that fires a small flame about the size of a pilot light, that is it. So, if your tank has propane, your regulator works, then follow the instructions and it should work. My guess is that you have a big hose that is filled with air that needs to be purged before you have gas coming out the jet. It may take as long as five minutes to get the air out of the hose so it will work, the jet is that small.

This unit works well on 120 and propane, but literally suck in 12 volts. The small heating unit draws 75 Watt of power, that is a lot, about 6 amps, will draw down your 50 amp starting battery in a heartbeat. The intended use is to plug it into the wall at home to get it down to temperature, use 12 volts when driving and change to propane when camping. A small 1lb propane cartridge lasts about 48 hours, or a weekend's use. No moving parts also means nothing ever wears out.
 

dwh

Tail-End Charlie
Yea, thermocouple.

But even if you get past that, you may still have a problem. Propane regulators come in both "high pressure" and "low pressure" versions:

http://gashosesandregulators.com/propaneregulatorfacts.html


Often (but not always) BBQs and big burners used for frying and whatnot are setup to use high pressure, and so they need a regulator that puts out high pressure.

Smaller appliances like stoves and fridges generally are setup to use low pressure, and so they need a low pressure regulator.

If you are using a BBQ regulator, make sure it's a low pressure type, or it probably won't be healthy for your fridge (IF the fridge will even work at all on high pressure).
 
dometic ammonia

and if it just doesn't cool it might need to be "burped". unhook the propane and electric,take the entire unit out and turn it upside down and leave it that way for 24 hours. YMMV
these coolers take a really long time to cool a case of beer to a civilized drinking temperature. it's far better to fill it with pre cooled or pre frozen food.
 

camper357

Observer
If it works on 120 then it does not need to be burped. It has three sources of heating, but only one set of cooling coils.
 

sqrlnts

New member
wow thanks for all the info and links. my issue is the gas knob will not push down to energize the thermo couple. I have tried soaking it with PB blaster but it seems stuck. Also mine has a red safety pushbutton below the gas valve not shown in the manual, could this be the button to push and I just have the wrong or mis- purged regulator? Thanks again for the help.
 
Last edited:

dwh

Tail-End Charlie
According to this manual:

http://www.hamqsl.com/RC2000.pdf

The gas knob pushes in when set to MAX. Also, it says that it needs a regulator that puts out "11 inches water gauge", which would be low pressure.

It also lists a procedure for cleaning the burner and jet. A clogged jet could be the problem (not likely, but possible).


As for that extra button...dunno. The manual for the RC4000 doesn't show an extra button either:

http://www.bensdiscountsupply.com/pdfs/Dometic-RC4000-Owners-Manual.pdf


Got a pic? All I can find look like this:

25703_2.jpg
 

dwh

Tail-End Charlie
Whack.

I would guess that the red button is either the hold down for the thermocouple pilot bypass (push and hold it to get the pilot lit instead of pushing the flame control knob down), or maybe a safety that you have to hold down in order to allow the flame control knob to push down.


Doing a quicky Google seach, every Precimex (you left out the r) regulator I see is a high pressure type.
 

sqrlnts

New member
ok, thanks again. I will have to locate a low pressure regulator before trying this again. Thanks ALL!!! I will update this once I get the regulator.
 
Top