BUILD:1993 Toyota HDJ80 - 1hdT, 5 Speed, 3x Locked, LHD. My dream vehicle!

BryceD

Member
PPD 3in mandrel bent turbo back exhaust installed... AMAZING!
lower EGTs
the sound is AMAZING
overall performance is drastically better

639302EA-AADB-4090-B309-109CCDC1BA44.jpeg

8E94FB33-128D-4467-9F86-6794AC39BD0A.jpeg

B544CD6D-1227-4894-87CD-E08F1EBAAADA.jpeg
 

BryceD

Member
I welded up some brackets to hold an axe and shovel on the roof rack. The downside of this OEM rack is lack of attachment points... everything can be either strapped on, or I gotta make a custom bracket.
2F0B1315-DA0C-466D-AB90-E95A82E0483C.jpeg


E024C7C5-D31E-4A80-87A4-202E61FB379E.jpeg


8C1BCBDA-826D-4944-AA7E-E01FB25C9DDB.jpeg

736677A4-5CF3-40B0-A2B1-36AB04D5151F.jpeg

54C8C183-2BB0-46C9-926C-8CB89877CC41.jpeg
 

BryceD

Member
Just installed mass loaded vinyl on The entire floor. What a big job! These are the only pics I got in the process.
E1E92B55-C426-4E53-9DEE-12B6C2E1AD4B.jpeg



0EB0AE67-FB89-49D2-B2FD-08138132F531.jpeg

BD8EC0AB-C475-4895-A965-1527C3125127.jpeg
 

BryceD

Member
Cold starting wasn’t what it used to be, so out with the old European batteries (who knows how old), in with the new Odyssey 27s. i cleaned up some wiring and replaced the terminals with mil spec as well. I also refinished the brackets with good ol rustoleum.

it feels like is starts before I even turn the key now, like an HDJ should! 910 CCA

63EDAB22-A1D7-49A7-87DB-E20898374E35.jpeg


7831E118-4F00-4795-BF73-4444ECBF5EAC.jpeg


F5222DA2-FD1E-4592-94F4-7292A55EDA2E.jpeg

88827EAA-A010-47E2-907F-1A8D099E4F24.jpeg

74D23EC3-1ED6-46B6-9812-D9FA0F4CB0A6.jpeg
 

getlost4x4

Expedition Leader
I have a top mount intercooler kit you need for that truck. Comes with the hood scope, fan, intercooler etc. Shoot me a message if you are interested. I was going to do a diesel swap (1HZ) on my Cruiser, but decided to go a different route. I also have a complete silicon hose kit lying around for that engine.

cool truck and build.
 

BryceD

Member
I have a top mount intercooler kit you need for that truck. Comes with the hood scope, fan, intercooler etc. Shoot me a message if you are interested. I was going to do a diesel swap (1HZ) on my Cruiser, but decided to go a different route. I also have a complete silicon hose kit lying around for that engine.

cool truck and build.
Hey there! Thanks for the offer. The truck has been running flawless with low temps and I love keeping as much original as possible at the moment. Maybe down the road I’ll reach out!
 

BryceD

Member
Well.... it happens. User error. Major regret... but I already found a straight door. Now I’m just looking for a nice front drivers quitter panel.

37E4A0FE-4AD6-4F1C-9537-3F7B91F33A52.jpeg

F25D2AEB-203F-4A81-AF71-771BCB8D09DD.jpeg

4ED3A9E8-A49B-43B7-AD8D-ADE26AB0028C.jpeg
 

BryceD

Member
the fender needed to come off because it was bent enough to prohibit the door from opening and closing. I removed both front quarter panels and discovered some patches from a snorkel this thing had in the past... WILD!

I cleaned them up and hit them with some rust reformer and rustoleum.

486F3C25-1784-45AB-8E92-85FAABDE1859.jpeg

31DBAF14-D9BE-4EA1-AAB8-05A6E9231078.jpeg

E8C25136-3CC7-47B7-A52E-10359DE1EAE9.jpeg
 

BryceD

Member
the truck has had troubles running at startup... it would slowly die at points...

after investigating, I found my fuel system was leaking and losing pressure. it was letting air in But hard to tell where. I would build pressure using the hand pump on the fuel filter, but after a minute it would lose pressure.

I proceeded to re build my pre filter system (racor 500fg) with all new seals and a new drain plug. I lso replaced all of the rubber fuel hoses and clamps. A new OEM fuel filter was swapped in as well... but...

after reassembling I found that the low level sensor at the bottom of the OEM filter was leaking... so I have a new sensor inbound.

39DE5711-7188-482C-80F5-7F25C0581276.jpeg

69E6E6FF-ACD1-4702-B5FF-AF19A5A1DB97.jpeg

2B9747CF-41F0-4C85-9C6F-53A2A8C7FE00.jpeg

3F444014-EC0D-47E9-B523-F71790826EE0.jpeg

BCD3A468-2AAF-42D8-87DC-87B45A8A86FB.jpeg
 

BryceD

Member
Building on this fueling issue:

after replacing the bottom sensor on the OEM filter (which seemed to be leaking) ANDA rebuilding the rancor unit with a new seal kit, there seemed to stil be loss of pressure!

I also replaced all hoses and clamps in the engine bay related to the fuel system.

I removed the racor unit and run it with just the OEM setup, and it runs great and hold pressure like it should.

I have rebuilt the Racor AGAIN while also using some high temp thread sealant on the in and out ports of the filter. I am letting that cure for a few days before running fuel through it. I will reinstall it when I receive my new OEM primer pump and fuel filter housing.
 

BryceD

Member
UPDATE ON FUELING ISSUE:

I removed the Racor unit and the truck runs and starts perfectly And reliably. It seems like the inlet and outlet (which we’re home made) we’re letting air in and pressure out.

now to I address this and keep the Racor installed? Or do I just run a small predicted and pump by the tank? Hmmmm
 

BryceD

Member
Installed the new 1upUSA bike rack on the swing out.... the hitch receivers corners were too tight... had to file the inside of the time to get it to fit... Now it’s snug as a bug.
F241011D-C8A8-4AB2-99E3-D2FE457EDF0C.jpeg
 
Top