ARB Fridge not working

NCLRbear

Adventurer
So my fridge just went down. it turns on and everything looks fine. you can even hear the the fan turn on. No error lights come on either but the fridge doesn't get cold at all. Im thinking the compressor went out or it leaked R134a. I bought it 4 years ago so its out of warranty. ARB said to ship it to them in Washington but the shipping would be close to $100 I think. I looked online and the compressor is less than $200 so I was thinking about taking it to a local appliance repair shop. Does anyone have any ideas?
 

Happykamper

Explorer
Sounds like your compressor. 200 for new compressor and 200-250 for labor. Unless you find an old school guy. That's 400-450.
Not sure what size you have but ... If it is done right it's better then 806 and up for new.
But I would take it in for a check, but that's going to cost also. But I am 99% sure it's your compressor. The fan will work forever.
Pretty odd it is only 4 years old. These are pretty reliable for long periods.
 

Stumpalump

Expedition Leader
The fan runs but is the compressor humming? Unplug the fan and listen. If not then see if the output from the controller is sending voltage to the compressor. If it's not sending voltage to turn on the compressor then it's a control problem. Calling ARB tech suport with solid troubleshooting may save you from shipping if it's not a compressor.
 

chmura

Adventurer
Download the ARB service manual. The service manual is in dept with pictures of the compressor, etc.

It has lots of instruction on how to check which major component failed or is causing the problem. Its a pretty good document that everyone with a ARB fridge should have.

If you find out what component failed maybe arb can send you just that part and install it yourself. Shipping these is not cheap especially if you don't have a corporate account with ups/fedex..

PM me and I will send it to you tomorrow.
 
Last edited:

NCLRbear

Adventurer
The fan runs but is the compressor humming? Unplug the fan and listen. If not then see if the output from the controller is sending voltage to the compressor. If it's not sending voltage to turn on the compressor then it's a control problem. Calling ARB tech suport with solid troubleshooting may save you from shipping if it's not a compressor.
Yes, I had a guy look at it yesterday. He said the compressor is running but barley. I'm just going to send it back to ARB and hope they can take care of me.

Download the ARB service manual. The service manual is in dept with pictures of the compressor, etc.

It has lots of instruction on how to check which major component failed or is causing the problem. Its a pretty good document that everyone with a ARB fridge should have.

If you find out what component failed maybe arb can send you just that part and install it yourself. Shipping these is not cheap especially if you don't have a corporate account with ups/fedex..

PM me and I will send it to you tomorrow.
I'll send the PM right now. On that note does anyone have an account number I could use? That isn't a charge account.
 

Stumpalump

Expedition Leader
Yes, I had a guy look at it yesterday. He said the compressor is running but barley. I'm just going to send it back to ARB and hope they can take care of me.



I'll send the PM right now. On that note does anyone have an account number I could use? That isn't a charge account.
Can you send me the manual as well? If you call ARB USA ask for Mitch in tech suport. He is the fridge master.
 

Badcoder

New member
Download the ARB service manual. The service manual is in dept with pictures of the compressor, etc.

It has lots of instruction on how to check which major component failed or is causing the problem. Its a pretty good document that everyone with a ARB fridge should have.

If you find out what component failed maybe arb can send you just that part and install it yourself. Shipping these is not cheap especially if you don't have a corporate account with ups/fedex..

PM me and I will send it to you tomorrow.

Any chance I could get the manual as well?
 

Superduty

Adventurer
So my fridge just went down. it turns on and everything looks fine. you can even hear the the fan turn on. No error lights come on either but the fridge doesn't get cold at all. Im thinking the compressor went out or it leaked R134a. I bought it 4 years ago so its out of warranty. ARB said to ship it to them in Washington but the shipping would be close to $100 I think. I looked online and the compressor is less than $200 so I was thinking about taking it to a local appliance repair shop. Does anyone have any ideas?


What eventually happened with this fridge? Did you send to ARB? How much was the repair? How much was shipping to and back?
 

Fireman78

Expedition Leader
Is it possible
To just send ARB the faulty compressor unit by itself?


Sent from my iPhone using Tapatalk
 

nwoods

Expedition Leader
FWIW, I sent a faulty ARB fridge back, paid the hefty shipping fee, but was very happy with the results. I never knew quite what was wrong with mine, but ARB opted to simply replace it with the newest generation fridge and all its little, but noteworthy enchancements. Sweet! Well worth the cost of shipping.
 

Superduty

Adventurer
FWIW, I sent a faulty ARB fridge back, paid the hefty shipping fee, but was very happy with the results. I never knew quite what was wrong with mine, but ARB opted to simply replace it with the newest generation fridge and all its little, but noteworthy enchancements. Sweet! Well worth the cost of shipping.
Was yours still in warranty?

Sent from my SAMSUNG-SM-G930A using Tapatalk
 
Top